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Agenda

Introductions

LabVIEW Overview

Common tools in LabVIEW (Theory)
LabVIEW exercises

FIRST specific code

Robot demonstrations

y NATIONAL

INSTRUMENTS



National Instruments Everywhere

More than 30,000 companies, including 90% of Fortune 500 manufacturing

companies use virtual instrumentation
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http://www.lego.com/eng/

Intro to LabVIEW

Environment




LabVIEW Graphical Development System

» Graphical programming environment
» Compiles code for multiple OS and devices
» Useful in a broad range of applications

LabVIEW Graphical Development Platform for Design, Control, and Test

Embedded Dasign Industrial Monitoring Automated Test

and Prototyping and Control and Measurament
. . Advanced Data Logging Communications
Filter Design/DSF Control HMI/SCADA and NVH Test
System Prototyping  Industrial Contral (PID) Maching Vision ATE
and Motion
Computing Targets

H_ ] L= I

Desktop Industrial Iobile Embedded
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Open and Run LabVIEW
Start»All Programs»National Instruments LabVIEW 8.6

s Stant I 13 National Instruments LabVIEW 8.6

rﬂ Getting Started Q ) ‘

File Operate Tools Help

Startup Screen: £ LabVIEW

New New To LabYIEW?
Sta rt f rom a b I an k VI . 4 Blank VI Getting Started with LabVIEW
| ] e
%) Empty Project LabYIEW Fundamentals
N ew B I a n k VI &1 Reak-Time Project Guide to LabVIEW Documentation
) More...
)) = LabVIEW Help
Upgradi abYIEW
Open
N Automatic Block Di m Clean Up
) Browse...
O r Quick Drop
Properties of Multiple Objects
ist of All New Features

Start from an example:
Examples»Find
Examples...

Training Courses
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R RRRRRRRRIRRRRR AR,
LabVIEW Programs Are Called Virtual Instruments (Vis)

Each VI has 2 windows (o s e oo e
+l@m ]
Front Panel e 2
» User interface (Ul) l
— Controls = inputs
— Indicators = outputs — :|| L
Block Diagram L e
* Graphical code SECDRERES

— Data travels on wires from controls
through functions to indicators
— Blocks execute by data flow
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Controls Palette

Control:
Numeric

(Place items on the front panel window)

Controils D

| »
[»

'Y

/

I
>
Iy
Iy
N

Signal Processing

Q Search ' o igw ¥
Modern
System
| > Classic

e Customize

T @ ¥ Mo

Y| 4 Palette
Mum Ctrl§ Buttons Text Ctrls V-

m’ 0/, —_J_g o 4 Iew

j T8 &
User Ctrl§ Murm Inds LEDs

> 3

Text Inds Graph Indifat...
Control Desian s S¥niistid

JNET & Active

Addons
User Controls

Select a Contral... \

> - - ™
13 Stide Exampfe.vi =) oEd
File Edit Yiewf Project Operate Tools ﬂindowjl'@
FlE
Mumeric Slide
436
ﬁ

& | I J

7ndicator:
Numeric Slide
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Control and Indicator Properties

* Properties are characteristics or qualities about an object
* Properties can be found by right- chckmg ona control or |nd|cator

* Properties include:
— Size
— Color
— Plot style
— Plot color .y

ﬂGraphP operties: Waveform Graph

! Appearance | Display Format | Plots | Scales | Cursors | Documentation | Datz: |»|

Label Caption
Visible [[] visible

‘Waveform Graph

BEEERRNNNEN | O oisabled oo
T [ s ") Disabled & grayed
* Features include: B O
. I [ show graph palette jtfr”“:’;je
) Chart
—_ Cursors [¥] show plot legend = :
Il

........... Auto size to plot names

_ Scaling 1 % Plots shown Show

[] show x scroll bar
"""""" [] show scale legend

"""""" [] show cursor legend e
........... || Optional plane lines
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Functions (and Structures) Palette

B8

Functions
Q, search | & view~ | 1|
| » Programming
| > Measurement 1jO
H » Ir)strurr_meljty?

|'» vision and Mation .
I s (Place items on the
| » Data Communication blOCk dlagram WlndOW)

[ »  Connectivity

[ » Control Design & Simulation - -
| » SignalExpress . . . bl
Tg— 13 Slide Example.vi Block Magram g@

[ » »
% Qz’ % File Edit “ew Project OQperate Toaols  Window  Help
[+=
3

Iniut’ Signal Ana:ysis olL:';l:Jt) "# @ @l II | @ @ ':::u ﬁ) uii‘
g8 o i -]

Sig Manip Exec Control  Arith & Compar

[ » addons
[ » Favorites

[ » User Libraries

\
| SelectaVl.. \\

| » Real-Time

| » FPGA Interface \
| > statechart \/

Structure:
While LOOp Ii] | i | *
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-
What Types of Functions Are Available?

* Input and Output

~ Signal and data simulation Express Functions Palette

— Real signal acquisition and generation with DAQ O‘ ch' ; —
— Instrument I/O Assistant (Serial and GPIB) ’
— ActiveX for communication with other programs M
+  Analysis
— Signal processing % ﬁ %
—~  Statistics s;',f”:, B
— Advanced math and formulas -
— Continuous time solver 3.
+ Storage
— File /O
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T
Searching for Controls, Vls, and Functions

Palettes are filled with hundreds
of Vis

Press the search button to index all

Vls for text searching

Click and drag an item from the
search window to the block diagram

Double-click an item to open the
owning palette

a8

Functions
QSearch‘ o Mg l =f I

[ » Programming

[ » Measurement IjO
| »  Instrument IfO

|'» vision and Motion
|'» Mathematics
| »  Signal Processing

| » Data Communication

[ » Connectivity
| »  Control Design & Simulation
[ » signalExpress

I Express .
-», ) ] l...—.u' Y
s =
Input Signal Analysis Qutput

>
E:E Functions B3

Sig Mani E: e g e
_ satene & f Q Return | 8 view~ |

> addons

iiibiFavorités tone

| > User Libraries -
| SelectaVvl... Basic Multitone with Amplitudes.vi [NI_MAPro.lvlib] [l
| » Real-Time Basic Multitone.vi [NI MAPro.lviib]

| > FPGA Interface
[ » Statechart

Extract Multiple Tone Information.vi [NI_MAPro.lvlib]
Extract Single Tone Information.vi [NI_MAPra.lviib]
Multitone Generator.vi [NI_MAPro.lviib]

)] Tone Extraction
@,‘! Tone Measurements [NI_ExpressFull.lvlib] < <Signal Analysis>>
g} Tone Measurements [NI_ExpressFull.lvlib] < <Waveform Measure
Tones and Noise Waveform.vi [NI_MABase. Ivlib]
Tones and Noise.vi [NI_AALBase. Iviib]

)

[> Search Options
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Status Toolbar
l@l B ] 13pt Application Font 1v‘ ;mvi e~ ﬁv‘ a ]

o || Run Button

& &| Continuous Run Button

Abort Execution

Additional Buttons on
the Diagram Toolbar

| [AzE Execution Highlighting Button

25 Retain Wire Values Button
ba|@|o®| Step Function Buttons
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Common Data Types Found in LabVIEW

Boolean Skring
¥. --------------------------------- I l“m.‘“
:TF : = | =14
Inkteger Error Clusker
—
o Y |
[o] 23 B ﬂ ="
0]
Double .
3
Array Simul?:e Signal
. ine
5 lj [1z= v
B 1] A
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Dataflow Programming

» Block diagram execution

— Dependent on the flow of data

— Block diagram does NOT execute
left to right

* Node executes when data is
available to ALL input terminals

* Nodes supply data to all output
terminals when done

—_
o
|
=
o
=
-

i
l

=
|
=
[
CL
1]

i
l

7
l
6

Simulake Signal

P Frequency

k

amplitude

Sine

Fesult

aveform Graph|

et
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Debugging Techniques

* Finding Errors

o Click on broken Run button.
Window showing error appears.

» Execution Highlighting

@ @ Click on Execution Highlighting button; data flow is
animated using bubbles. Values are
displayed on wires.

* Probes
S0 0 Right-click on wire to display probe; it shows data as it flows
Nt through wire segment.
) You can also select Probe tool from Tools palette and click
«E-|  on wire.
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Demo: Simulate Signal to Graph

13 1 Simulate Signal.

vi

B]f=1]]

13 1-Simulate Signal.vi Block Diagram

File Edit View Project

Operate  Tools Window Help

#|®|@[n]

File Edit Wew Project ©perate Tools ‘Window Help

[ [@[ ][9]z bo & o

‘Ampl itde
ﬂél—
Freguency
J40.1

Waveform Graph

Aamplicude

Sine

[L\I'-DAQ Hands-on Exercises. lproj/My Computer [( ] | 1

Frequency
[DBLH

Amplitude

e

Simulate Signal
Sine

Waveform Graph

skop

el

[LV-DAQ Hands-on Exercises. lvproj/My Computer[< ] [

[2)

* Simulate various signals
* Write to Graph

ni.com
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Context Help Window

* Help»Show Context Help, press the <Ctrl-H> keys
* Hover cursor over object to update window

Context Help D

Extract Single Tone Information.vi

Additional Help rr==mexported signals

time signal in — detected frequency

' . . export signals — Aj‘_ S . = detected amplitude
— ng ht-Cl ICk O n th e Vl I CO n a n d error in {no error) == gl tdetected phase {(deq)
advanced search error out
measurement info

Ch Oose H e I p ) Or Takes a signal in, finds the single tone with the highest amplitude

or searches a specified frequency range, and returns the single
tone frequency, amplitude, and phase. Wire data to the time

- C h Oose ¢ Detai Ied h el p” O n th e signal in input to determine the polymorphic instance to use or

manually select the instance.

Detailed help ™
[EE[2]< [2].::

context help window
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Tips for Working in LabVIEW

 Keystroke Shortcuts
— <Ctrl-H> - Activate/Deactivate Context Help Window
— <Ctrl-B> - Remove Broken Wires from Block Diagram

— <Ctrl-E> - Toggle between Front Panel and Block
Diagram
— <Ctrl-Z> - Undo (also in Edit menu)
* Tools»Options... — Set Preferences in LabVIEW

* File»VI Properties — Configure VI Appearance,
Documentation, and so on
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Elements of Typical
Programs




LOOpS While Loop

 While Loop

— [i] Terminal counts iterations :
— Alwaysruns atleastonce |  Fe= el il
— Runs until stop condition is met o

 For Loop

_0d Terminal counts iterations

— Runs according to input N of
count terminal 1N
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Three Types of Functions (from the Functions

Palette)

Express VIs: interactive Vls with configurable dialog page (blue border)

Signals
amplitude »

Freguency *
e

Standard Vls: modularized Vls customized by wiring (customizable)

[Extract Single Tone Information. i

EHHF:

Freg.

Functions: fundamental operating elements of LabVIEW; no front panel or
block diagram (yellow)

rUlkiply

7 NATIONAL
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How Do | Make Decisions in LabVIEW?

(b)
2. Select
— =7 b f
= — %ﬁ?
B— (g
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Charts — Add 1 Data Point at a Time with History

Q search ‘ e View ' =f ‘

Waveform chart — special numeric indicator that can display a ;e
history of values 3
« Chart updates with each individual point it receives =
Controls»Express»Graph Indicators»Chart
100 HN
W aveform Chart Plok 0 m

b aveform Chart|

Time Delay

i
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Graphs - Display Many Data Points at Once

Waveform graph — special numeric indicator that displays an
array of data

« Graph updates after all points have been collected
 May be used in a loop if VI collects buffers of data

Controls»Express»Graph Indicators»Graph
[Lo0 N

.~

Time Delay

i

ontrolke 5|
Q, Search ' o it ' =f l
» Modern
b System
P Classic
|' ¥ Express
L Graph Indicators
2
|
Chart XY Graph
b NET & ActiveX
| Select a Contral...
ot 1A%

il

H Iju\ r ‘ ~ ‘}\

I I I
40 a0 BI:I 100

IIH

‘7 NATIONAL

INSTRUMENTS



-
Shift Register — Access Previous Loop Data

« Available at left or right border of loop structures

* Right-click the border and select Add Shift Register

» Right terminal stores data on completion of iteration

« Left terminal provides stored data at beginning of next iteration

Initial __ 5 =/ — Value 15
Value

Before
Loop First Second Last
Begins lteration lteration lteration
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Sequence Structures

* Control execution sequences in LabVIEW
EEY)

(M O0000000000000000O0O00O0 0000000000000 0000000000000000A0C

Waveform Graph

3

Wavef Graph 2
DAD Assiskant H‘mm averorm larap
data ) L

Tt

L A e e

|'EIElEIElEIEIElElElEIEIEIElElI:IEIEIElEIElL'IEIElEIElEIEIEIEIEEII:IEIElElElEIEIElEIElEIElEIEIElElElEIEIEl'
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Creating SubVis

* Enclose area to be converted into a subVI
« Select Edit»Create SubVI from the Edit menu

v2| [Slope = RisefRun|
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Creating an Array (Step 1 of 2)

From the Controls»Modern»Array, Matrix, and Cluster subpalette,

select the Array icon.

\

Controls
Q Searchy| oo View ™ ‘
|¥ Moder
L AerMatrix & Cluster
¥3

— -]
. Lt
Array Cluster

ComplexMatri... Error In 3D.ctl Error Out 3D.ctl

ﬁrri—é;stem

W P Classic

| > Express

Mibi Controirbesign & Simulation

| » .MET & ActiveX

| » signal Processing

| » addons

| »  User Controls

| Selecta Contral...

Drop it on the front panel.

O N B I
Fra

|
R
i
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Create an Array (Step 2 of 2)
1. Place an array shell.
2. Insert data type into

Controls [:| [
Q, search | & view |
[ » Modern
|| > System
| » Classic
\; Express

nell (i.e., numeric control).

|

|

_.I“i_._._._._..

I I I I I
|
-
o

I O

: : : : : : T : @ : :
[ [ [ [ [ [ [T eI

D )
vl
'llllm

L Mumeric Controls

Hiz3] st .

“ ' 05 10 05 10
Mum Cerl Fill Slide Pointer Slide

10- 10- 8

1 3 A

o- o-B =
Fill Slide Pointer Slide Knob

Dial Color Box

| »  Control Design & Simulation
> NET & Activex BEESEEE
[ »  signal Processing 5 It 1 I
| » addons
| » User Con 1. gy
[ Selectaca = e
1

I Y25 X o

|

£ i F I fi fi fi fe f
740 f’l:l f’l f’z f’S 1'-’4 1[-’5 .'-’I:I +’I:I a
|

(T (1 1 (0 ) Y () (1

I T I | I I I I
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Introduction to Clusters

» Data structure that groups data together

 Data may be of different types

* Analogous to structin ANSI C

 Elements must be either all controls or all indicators
» Thought of as wires bundled into a cable

* Order is important

V77774
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Cluster Functions

* |n the Cluster & Variant subpalette of the Programming palette
* Can also be accessed by right-clicking the cluster terminal

cormponent 1 —5g
_H"'“’ cluster
compaonent 1 B

\(Terminal labels
reflect data type) ,
Bundle e Fiew dotel]

............ Switch 2 I:-_n
Bundle By Mamne

It clustermﬂ

hew camponent & | owned label &
niew component B~ qwned label B

== oLtpLt cluster

Bundle By Name

y NATIONAL
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Local Variables

* Local variables allow data to be passed between parallel loops

* You can read or write a single control or indicator from more than one
location in the program

— Local variables break the dataflow paradigm and should be used sparingly

:Numeric
(D8]
= Visible Items >
Find Control
Loop & Hide Control
Change to Indicator
Change to Constant
Description and Tip...
it 111 MNumeric Palette » J 77777777777
Create » | Constant
 Data Operations 4 Control
Advanced > Indicator
Representation »  Local Yariable
e | Reference D§
Property Node »
Properties Invoke Node  p

V NATIONAL
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Global Variables

- Use very sparingly!!

» Used to communicate between VI’s in a project
* Can cause race conditions
* When using - call in a subVI
 Can cause performance problems
* Not the most efficient use of memory

y NATIONAL
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Variable
Exercise




C. Functional Global Variables

* The general form of a functional global variable
includes an uninitialized shift register (1) with a
single iteration For or While Loop

Function Glaobal Wariable Code

Input
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SAVE YOUR FILES!!




T
Additional Resources

NI FIRST Community

http://www.ni.com/first

Tutorials, Support, Specifications, etc.

fsconnexions*
sharing knowledge and building commmunifies

Harme

Connexions: Full LabVIEW Training Course
— www.cnx.rice.edu

Or search for “LabVIEW basics”

RELATED MATERIAL

LabVIEW Envir
Similar content

By MATIOMAL INSTRUMENTS
= Lab%IEW Graphical

BBBBBBBB summary: In this section, you

Get your own copy of LabVIEW Student Edition
— Www.ni.com/academic

LabVIEW u,]
63‘96 'y
\)Q \N By Robert H Bish
\’3‘6 y Robe ishop.
= Published by Prentice Hall.
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http://www.ni.com/first
http://www.ni.com/academic
http://www.phptr.com/authors/bio.asp?a=680855aa-0b6f-441f-8280-53f8f7b5f51b
http://vig.prenhall.com/

Ensuring YOUR Success
Join the

ity - Windows Internet Explorer

<]

" . 5 v | W httpsjidecibel.ni.comjcontent/communityfirst ) | *:
* ni.com l f I rst N =
. %A

NATIONAL T
INSTRUMENTS' . eirch 2

¢ S s u p po q u es I o n s e i

B i

o/ New - & My Profile & Tools = [ History

] u ]
¢ CCGSS tra NN mate I'Ia [y FIRST Community
rimsy Welcome to the National Instruments Community for FIRST Robotics. Read the latest training tutorials. watch cool videos. download example pri
engineers from around the world. FIRST Community content is intended for users 13 & up
d t h . I
I t t i Community Spotlights

* [nteract with other teams
and mentors

) Browse

Overview

| sctos defautttab

Getting Started Resources

O — e I

The New Control System
National Instruments Video Playlist

Information about the new controller and resources to aid in getting started.
Description: This video playlist showcases cutting edge engineering and student

solutions. This includes many robotic applications using LabVIEW, CompactRIO,

% NI LabVIEW Programming
and many other National Instrument products.

Great resources for exploring and learning the NI LabVIEW graphical programming
To see even more videos, check out the NFirstRobotics YouTube Channel environment
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